Header Ads

Cara Setting Mikrotik External Proxy


Logo Squid Proxy
Logo Squid Proxy

Web Proxy yang dimiliki internal Mikrotik (Squid) kurang begitu bagus performanya dibandingkan web proxy squid aslinya. Kelemahannya adalah kita tidak bisa melakukan konfigurasi pada squid tersebut. Sehingga kita tidak bisa melakukan konfigurasi tuning ataupun settingan Access Control List (ACL). Banyak user Mikrotik kemudian menambahkan konfigurasi external proxy sehingga mendapatkan fitur yang lebih complex daripada fitur internal proxy.
Berikut skema diagram jaringannya :
Modem---Mikrotik---Client
                      |
                      |
                  Proxy

Misal :
dari Modem=192.168.1.254/24
Mikrotik=ether1 (ke modem)192.168.1.1/24
Mikrotik=ether2 (ke proxy)192.168.2.1/24
Mikrotik=ether3(ke client)192.168.3.1/24
Proxy=192.168.2.2/24
Client=192.168.3.2-10/24
Konfigurasi ip address
ip address add address 192.168.1.1 netmask 255.255.255.0 interface ether1
ip address add address 192.168.2.1 netmask 255.255.255.0 interface ether2
ip address add address 192.168.3.1 netmask 255.255.255.0 interface ether3

Menambahkan IP DNS
ip dns set primary-dns=180.250.13.50 di sini saya gunakan IP DNS Speedy

Menambahkan IP Gateway
ip route add gateway=192.168.1.254  di sini saya gunakan IP Modem Speedy

Untuk proxy, lakukan konfigurasi pada bagian NAT sebagai berikut :
/ip firewall nat add chain=src-nat src-address=192.168.2.2 out-interface=ether1 action=masquerade

Sedangkan NAT untuk komputer client :
/ip firewall add chain=src-nat src-address=192.168.3.0/24 out-interface=ether1 action=masquerade
Kemudian jangan lupa, client dipaksakan harus browsing lewat proxy (misal proxy dibuka diport 3128) maka :
/ip firewall chain=dst-nat src-address=192.168.3.0/24 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.2 to-ports=3128

Untuk setingan proxy bisa anda baca di sini sesuaikan alamat ip addressnya

Baca artikel menarik lainnya
1. Setting Hotspot Mikrotik
2. Cara Instalasi mikrotik di PC Router
4. Manajemen bandwidth dengan simple queue
5. Setting IP Adress Mikrotik melalui terminal

2 comments:

  1. Gan...untuk client apa sudah otomatis???atau harus di setting dulu proxy di browser client???

    ReplyDelete

Powered by Blogger.