Header Ads

Load Balance Mikrotik dua Modem Indihome dengan metode ECMP

Artikel sebelumnya telah di bahas beberapa metode load balance yang bisa di terapkan pada RouterOS Mikrotik, nah kali ini akan coba di implimentasikan dengan topologi menggunakan dua buah modem indihome sebagai akses internet dengan menggunakan dua jalur.
Berikut langkah konfigurasinya
Konsep jaringan
Modem 1
Ether1 terhubung ke modem 1 yang mempunyai IP address 192.168.10.1/24
Modem 2
Ether2 terhubung ke modem 2 yang mempunyai IP address 192.168.20.1/24
Langkah 1 Masing masing interface kita beri tanda comment

/interface
commen ether1 comment=ISP1
commen ether2 comment=ISP2
commen ether3 comment=Local

Langkah 2 konfigurasi interface router

ether1 : 192.168.10.2/24
ether2 : 192.168.20.2/24
ether3 : 192.168.100.1/24
IP > Addresses > Add (+)
Address : 192.168.10.2/24
Network : 192.168.10.0
Interface : ether1

IP > Addresses > Add (+)
Address : 192.168.20.2/24
Network : 192.168.20.0
Interface : ether2

IP > Addresses > Add (+)
Address : 192.168.100.1/24
Network : 192.168.100.0
Interface : ether3

Langkah 3 tambahkan default routing
IP > Routes > Routes > Add (+)
Dst. Address : 0.0.0.0/0
Gateway : 192.168.10.1 dan 192.168.20.1
Check Gateway : ping

Dengan mengaktifkan check gateway, maka sistem failover juga akan aktif. Artinya, jika salah satu gateway mati, secara otomatis hanya gateway tersebut tidak aktif.
Metode load balance yang di gunakan ini menggunakan algoritma round robin. 
Misal ISP 1 memiliki banwidth 10Mbps dan ISP 2 memiliki banwidth 10Mbps, maka perbandingannya adalah 10:10 = 1:1, sehingga dituliskan gatewaynya masing - masing hanya satu. Tetapi jika ISP 1 : 10Mbps dan ISP 2 : 20Mbps, maka perbandingannya 10:20 = 1:2, sehingga gateway nya menjadi : ISP1, ISP2, ISP2 (192.168.10.1 192.168.20.1 192.168.20.1).
Langkah 3 Konfigurasi IP DNS

IP > DNS
Server : 8.8.8.8 dan 8.8.4.4

Allow Remote Requests : checked
Langkah 4 Konfigurasi Firewall Mangle

/ip firewall mangle
add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ISP1_conn
add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ISP2_conn
add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1
add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2


Langkah 5 Menambahkan nat

Menambahkan nat interface ether1

IP > Firewall > Nat > Add (+)
General > Chain : srcnat
General > Out. Interface : ether1
Action > Action : masquerade
Menambahkan nat interface ether2

IP > Firewall > Nat > Add (+)
General > Chain : srcnat
General > Out. Interface : ether2
Action > Action : masquerade

Check koneksi
Cobalah ping dan tracert ke IP luar internet, misalkan ke google IP 8.8.8.8

tool > traceroute 8.8.8.8

Putuskan koneksi salah satu gateway dengan cara matikan modem salah satu, dan 
cobalah trace kembali. Seharusnya koneksi bisa berpindah dari modem satu ke modem 
yang lain, nah sampai di sini konfigurasi sudah selesai semoga berguna....


No comments

Powered by Blogger.